Forums Instiki

macOS nokogiri

Subscribe to macOS nokogiri 3 posts, 2 voices

ifoerster 1 post

Hello, I try to install instiki on macOS but the gem file always produce an error:

Fetching Fetching gem metadata from……. Fetching version metadata from Resolving dependencies… nokogiri- requires ruby version >= 2.1.0, which is incompatible with the current version, ruby 2.0.0p648

Anybody can help here?

distler Moderator 123 posts

edited 7 years ago

Hmmm. That’s unexpected. You can edit the Gemfile to replace the line

gem "nokogiri", '~>1.7.0'


gem "nokogiri", '~>1.6.0'

which should work fine.

Or you can install a more recent version of Ruby (current is 2.4.0; you have 2.0.0).

Forums Instiki