Forums Instiki

Installation/Upgrade Issues

Subscribe to Installation/Upgrade Issues 7 posts, 2 voices

mmadsen 5 posts

Hi, I’m having trouble both upgrading an existing Instiki installation (0.19.1)MML+, and installing a plain vanilla 0.19.3 from github.

The issue seems to surround iconv, and none of the solutions or suggestions I’ve tried from googling have worked.

The platform is OSX Lion, using Ruby 1.9.2_p180, gcc compiler version:

Using built-in specs. Target: i686-apple-darwin11 Configured with: /private/var/tmp/llvmgcc42/llvmgcc42-2336.1~1/src/configure –disable-checking –enable-werror –prefix=/Developer/usr/llvm-gcc-4.2 –mandir=/share/man –enable-languages=c,objc,c++,obj-c++ –program-prefix=llvm- –program-transform-name=/^cg/s//-4.2/ –with-slibdir=/usr/lib –build=i686-apple-darwin11 –enable-llvm=/private/var/tmp/llvmgcc42/llvmgcc42-2336.1~1/dst-llvmCore/Developer/usr/local –program-prefix=i686-apple-darwin11- –host=x86_64-apple-darwin11 –target=i686-apple-darwin11 –with-gxx-include-dir=/usr/include/c++/4.2.1 Thread model: posix gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)

The installation of 0.19.3 seems to go well, ruby bundle pulls down everything 0.19.3 requires, but the following occurs upon attempting to start instiki:

mark:instiki-0.19.3/ (master) $ ./instiki -p 2501 14:26:37 NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01. Gem.source_index called from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/railties/lib/rails/gem_dependency.rb:21. /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/inflector.rb:3:in require': no such file to load -- iconv (LoadError) from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/inflector.rb:3:in <top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext/integer/inflections.rb:1:in `require' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext/integer/inflections.rb:1:in `<top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext/integer.rb:2:in `require' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext/integer.rb:2:in `<top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext.rb:8:in `require' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext.rb:8:in `block in <top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext.rb:8:in `each' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support/core_ext.rb:8:in `<top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support.rb:56:in `require' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/vendor/rails/activesupport/lib/active_support.rb:56:in `<top></top>(required)>' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/script/server:7:in `require' from /Users/mark/Dropbox/Research/Instiki/instiki-0.19.3/script/server:7:in `<top></top>(required)>' from ./instiki:6:in `load' from ./instiki:6:in `<main>'</main>

I had previously rebuilt ruby 1.9.2 in rvm, after doing rvm pkg install iconv and rebuilding 1.9.2 pointing at the rvm version of iconv, as suggested online.

I’m stumped. Has anyone else seen this? What did you do to solve it?


admin Administator 63 posts

Hmm. And does

# irb
> require 'iconv'

return 'true'? What does

#  /usr/bin/env ruby -v


mmadsen 5 posts

require ‘iconv’ returns:

1.9.2p180 :001 > require ‘iconv’ LoadError: no such file to load – iconv from internal:lib/rubygems/custom_require:29:in require' from <internal:lib/rubygems/custom_require>:29:in require’ from (irb):1 from /usr/local/rvm/rubies/ruby-1.9.2-p180/bin/irb:16:in <main>'

and when I try to install iconv as a gem:

bash-3.2# gem install iconv Fetching: iconv-0.1.gem (100%) Building native extensions. This could take a while… ERROR: Error installing iconv: ERROR: Failed to build gem native extension.

    /usr/local/rvm/rubies/ruby-1.9.2-p180/bin/ruby extconf.rb

checking for iconv() in iconv.h… no checking for iconv() in -liconv… no *** extconf.rb failed ***

mmadsen 5 posts

Fixed. Had two ruby 1.9.2 installations in rvm, one had the iconv stuff fixed, one didn’t. Will try the instiki upgrade again. Thanks for pointing me in the right direction!

mmadsen 5 posts

Or….not quite there yet.

irb require iconv is great

starting instiki 0.19.3 from the command line is great

starting instiki from the plist with launchctl is saying ” Bundler couldn’t find some gems.Did you run bundle install? (RuntimeError)”

since it does not give this error when run from the command line, and “ruby bundle install” and bundle update come up clean, I’m assuming that somehow this is running with the wrong context out of the launch daemon plist given multiple rubies in the system under rvm (although the default is set).

so I edited the instiki shell script to point to the correct, specific ruby directory, and I still get the same thing in system logs when using launchctl.

at all points, launchctl is being executed as unprivileged user, and specifies the same unpriviliged user in the plist file.

Has anyone encountered this before?

admin Administator 63 posts

Launchd doesn’t play well with RVM. There are workarounds, e.g. here.

mmadsen 5 posts

Thank you for your help!

Forums Instiki