Forums Instiki

Installation problem

Subscribe to Installation problem 10 posts, 2 voices

 
handy 9 posts

Hi there,

  • I’m running Arch Linux.

I’ve installed: * ruby 2.4.2p198 * Created ~/.gem/ruby/2.4.0/bin ruby_gems updated (have multiple directories & files in …/2.4.0/ now)

Ran a couple of tests (found on the web) & Ruby seems to be functioning OK.

  • used the following to install instiki: gem install instiki ~/.gem/ruby/2.4.0/bin/

When I enter ./instiki –daemon I get the following errors:

‘code’ [handy@notebang ~/.gem/ruby/2.4.0/bin]$ ./instiki –daemon /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/instiki:6:in load': /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/script/server:27: formal argument cannot be a constant (SyntaxError) 'Default: 2500') { |OPTIONS[:port]| } ^ /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/script/server:27: syntax error, unexpected '[', expecting '|' 'Default: 2500') { |OPTIONS[:port]| } ^ /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/script/server:30: formal argument cannot be a constant 'Default: 0.0.0.0') { |OPTIONS[:ip]| } ^ /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/script/server:30: syntax error, unexpected '[', expecting '|' Default: 0.0.0.0') { |OPTIONS[:ip]| } ^ from /home/handy/.gem/ruby/2.4.0/gems/instiki-0.10.2/instiki:6:in

<top></top>(required)>' from ./instiki:23:in `load' from ./instiki:23:in `<main>' '/code'</main>

Any help will be much appreciated.

 
distler Moderator 110 posts

I would not expect the (ancient!) gem version of Instiki to work at all.

What you need to do is

git clone https://github.com/parasew/instiki.git
cd instiki
ruby bundle install  --path vendor/bundle

Then, if all went well,

ruby ./instiki --daemon
 
handy 9 posts

Thanks for your reply. :)

I installed git, & then followed your instructions & installed instiki. (The AUR package is certainly out of date!)

Then I ran instiki, intered a wiki name/address for my local wiki & a password.

When I hit the next button I get a “HomePage” with the following error:

Routing Error

No route matches “/handy.wiki/show/HomePage” with

Once again I’m at a loss?

If you could please point me in the right direction I’ll be very grateful?

 
handy 9 posts

I’ll try the code option before I read the wiki page again: ;)

‘code’No route matches “/handy.wiki/show/HomePage” with ’/code’

 
handy 9 posts

OK I read your wiki page on the syntax, so here is my error in full:

<nowiki>No route matches "/handy.wiki/show/HomePage" with {:method=>:get}</nowiki>
 
distler Moderator 110 posts

I assume you’re running on localhost?

In that case, you should be able to access the URL

http://127.0.0.1:2500/

If you have more than one wiki (“web” in Instiki’s idiosyncratic parlance), this will redirect to

http://127.0.0.1:2500/web_list

If you have only one web configured it will, instead, redirect to the HomePage of that web.

 
handy 9 posts

Thanks for your reply.

I have only one “web”.

Unfortunately I still get exactly the same result when using the address that you provided in the above post?

 
distler Moderator 110 posts

edited about 1 year ago

Can you access

http://127.0.0.1:2500/web_list

? If so, what are all the links on that page?

(Clearly, something got screwed up in creating your first wiki. If we can’t straighten this up, I’d suggest reinstalling.)

Edit: To be clear, a full reinstall is probably not necessary. A simple

kill <pid-of-instiki>
git checkout -- db/production.db.sqlite3
ruby ./instiki

will suffice to reset the database.

 
handy 9 posts

Thanks for your help. We got it this time. :)

I used the command you suplied above, & started the setup again & it is working fine now.

Thanks for your time.

Forums Instiki