Forums Instiki

problem running instiki after installation

Subscribe to problem running instiki after installation 4 posts, 2 voices

 
yoyoma 2 posts

edited over 1 year ago

Hi all, first time poster. Sorry if this has been discussed before, but I didn’t find anything on a quick search. I am running ubuntu 10.04, I followed all the instructions on your installation page for ubuntu. Everything seemed to install ok, I did all the apt-get and bundle install, but when I tried to run “./instiki –daemon” I get the following errors, fyi, my version of ruby is 1.8.7, patchlevel 249).

Thanks for your help, Ron


/usr/lib/ruby/1.8/rubygems/dependency.rb:52:in `initialize': Valid types are [:development, :runtime], not nil (ArgumentError) from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:352:in `new' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:352:in `search' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:346:in `gems_size' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:179:in `resolve' from /usr/lib/ruby/1.8/rubygems/source_index.rb:95:in `sort_by' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `each' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `sort_by' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `resolve' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:160:in `start' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:128:in `resolve' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:127:in `catch' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/resolver.rb:127:in `resolve' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/definition.rb:151:in `resolve' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/definition.rb:90:in `specs' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/definition.rb:135:in `specs_for' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/definition.rb:124:in `requested_specs' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/environment.rb:23:in `requested_specs' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler/runtime.rb:11:in `setup' from /home/riovine/instiki/instiki-svn/vendor/plugins/bundler/gems/bundler-1.0.18/lib/bundler.rb:107:in `setup' from ./config/../config/preinitializer.rb:18 from ./config/boot.rb:28:in `load' from ./config/boot.rb:28:in `preinitialize' from ./config/boot.rb:10:in `boot!' from ./config/boot.rb:124 from ./script/server:3:in `require' from ./script/server:3 from ./instiki:6:in `load' from ./instiki:6
 
distler Moderator 81 posts

I followed all the instructions on your installation page for ubuntu.

What page are you talking about?

 
yoyoma 2 posts

http://golem.ph.utexas.edu/wiki/instiki/show/Installation, the part that talked about ubuntu

 
distler Moderator 81 posts

Probably, those instructions are out-of-date. (Help updating them would be appreciated.)

It would be best to ensure that you have a fully-functioning Ruby (1.9.3 is preferable) installation before proceeding with getting Instiki running. Perhaps these instructions might help.

Forums Instiki