Bugs

Subscribe to Bugs 13 posts, 3 voices

 
admin Administator 57 posts

Let’s discuss bugs in Heterotic Beast.

 
distler 77 posts

edited 3 years ago

Hmmm. /users/nnn/posts?monitored=true doesn’t seem to return anything, here on Golem. But it works fine on my test installation.

Both are running in production mode. The test installation uses sqlite3; this one uses mysql. The (admittedly complicated) SQL join seems not to work on the latter.

Hah! Fixed, now. Boolean comparisons are not the same in SQLite3 and MySQL. Finding a syntax that works in both was … umh … fun.

 
Andrew Stacey 118 posts

This place doesn’t seem to remember me at the moment. *sigh*

 
Andrew Stacey 118 posts

Is the colour of the icon next to the forum title meant to tell me if there’s new stuff there? If so, it’s not always in sync.

 
Andrew Stacey 118 posts

When I click on a discussion/whatever then it takes me to the top of the page. It would be more sensible if it took me to the point where I last read up to (which I presume it knows).

 
distler 77 posts

edited 3 years ago

Layer 1

It would be more sensible if it took me to the point where I last read up to (which I presume it knows).

How does Vanilla keep track of what posts you’ve read?

 
Andrew Stacey 118 posts

Incidentally, if you want to get a feel for what Vanilla looks like but don’t want to sign on to the nForum, I have a test forum set up: http://www.math.ntnu.no/~stacey/Mathforge/Test/. I can easily add any plugins from the nForum that you might want to play with.

 
Andrew Stacey 118 posts

Vanilla stores some information in the user database, including the last comment in each discussion that you read.

 
Andrew Stacey 118 posts

May I suggest ”Other users online: XYZ”.


Okay, that’s odd. I suggested the above having seen the “Users online: distler” message, and not seeing my own name. Now I click back to the forums list and I am listed there this time. So either it got it wrong first time, or you’re playing with the code and I should shut up and let you get on with it.

 
Andrew Stacey 118 posts

Deleting the first post in a topic leads to a “page does not exist” error.

 
distler 77 posts

edited 3 years ago

No it doesn’t.

Deleting the only post in a topic, also deletes the topic. Possibly, the redirect (which normally goes to topic#show but, in this case, should go to the forum#show because the topic no longer exists) is incorrect.

Fixed.

 
Andrew Stacey 118 posts

Long lines (of code?) make the posts a bit wide. Currently, my view on http://golem.ph.utexas.edu/forum/forums/instiki/topics/bugs#post_77 has all the posts reaching in to the grey region on the right-hand side.

 
Andrew Stacey 118 posts

This place just remembered who I am. So that seems to be working now.